Search This Blog

Tuesday, July 17, 2012

Windows 7 missing/forgot VCPU's

I made a Windows 7 Virtual Machine (VM) with 2 CPU's and it worked fine. I then wanted to add 2 more CPU's to it for a total of 4 to test, but the VM would only show 2 CPU's. This is how I fixed it.
1.Power off the Virtual Machine (VM)
 2.Edit Settings on the VM


















3.Select Options (red), General (blue), Configuration Parameters (green)











4.Click “Add Row” (black), Enter [ cpuid.coresPerSocket ] (pink), Enter [ 2 ] (yellow)








5.Click OK and power on the VM.

Wednesday, July 13, 2011

Outlook delay when typing in the address fields

Microsoft Outlook delays when I type in the address fields. I have found 3 possible problems for this:

1. Mcafee antivirus.

Solution
Click Start, Programs, McAfee, VirusScan Console.
Right-click Buffer Overflow Protection and select Properties.
Under Buffer overflow exclusions, click Add, type the process name and click OK.
Click OK.

2. Outlook addin

Solution
In Outlook 2007, go to Tools, Trust Center
Click on the Add-ins section
Click on the add-in you want to disable and then click on the Go.
You will be presented with a list of addins just uncheck the box to disable the addin
restart outlook.

3. Outlook autocomplete/cached email addresses.

close Outlook
open windows explorer and go to "%APPDATA%\Microsoft\Outlook"
rename Outlook.NK2 Outlook.NK2.old
restart Outlook

Hopefully one of these will help you as it did me.

Tuesday, March 8, 2011

Google Search Redirect

I found a rootkit on a machine that redirects the search results from google. The person would type the search in the search box hit enter and google would come back with the results when the user would click on the results they are sent to random web page.
How to fix this.

Download ATF Cleaner and save it to your desktop.
This will delete you temporary files
Download link
Run ATF-Cleaner.
Under main select All
Click the empty button.

If you use Firefox browser

Click Firefox at the top and choose: Select All
Click Opera at the top and choose: Select All

Next:
Download TDSSKiller and save it to your Desktop.
Download link
Unzip it.
Run TDSSKiller, then on Start Scan.

















This is what I found I cleaned it and rebooted.




















Fixed :)

Source website

Wednesday, December 8, 2010

Transfer a stand alone server user accounts to new standalone server

I needed to make a new stand alone FTP server for my company, so I needed to find away to export the user accounts and import them into a new stand alone FTP server, and this is what I came up with.

1. Export the user accounts into a text file. Right click on the my computer or computer icon and click manage. Then click on local users and groups and right click on users click export list type the name of the file ( I named mine userlist.txt ) ( file) .txt and save it to the c drive. (c:\userlist.txt)



You text file should look like this:

Name Full Name Description
administrator administrator Built-in account for administering
Guest Guest Built-in account for guest access to the computer/domain

2. Now you can edit the text file and leave just the usernames.

administrator
Guest

3. Create a new text file and copy the following into it:

:: This line creates a username from the list and set's the password to admin
for /f "tokens=1" %%a in (userlist.txt) do net user %%a admin /add
:: This line adds them to a local group like Backup Operators
for /f "tokens=1" %%a in (userlist.txt) do net localgroup Backup Operators %%a /add
:: This line removes them from a local group like users
for /f "tokens=1" %%a in (userlist.txt) do net localgroup users %%a /delete
:: This line makes a directory for it on the c:\ftproot\localuser
for /f "tokens=1" %%a in (userlist.txt) do mkdir C:\ftproot\localuser\%%a

4. Rename the text file you pasted that into to user.cmd

5. Run it.

Advice: I would suggest you try a list with 2 names in it first work out the bugs before you do the full import.

Thats it.

Variations on this idea

What if you want to keep the passwords:
You need to a password text file and put it in with the user names separated by a tab
administrator areallygoodpassword
Guest Areallyreallygoodpassword

:: This line creates a username and set's the password to second entry in the list

for /f "tokens=1,2" %%a in (userlist.txt) do net user %%a %%b /add

What if you want to random passwords:

:: This line creates a username and Randomizes the password and redirects it into a c:\passwords.txt file.
for /f "tokens=1" %%a in (userlist.txt) do net user %%a /add /random /passwordchg:yes >c:\passwords.txt

Thursday, November 11, 2010

Cisco Basic Frame Relay Config

I recently needed to install a Cisco router on a frame relay and forgot how. Trust me it's been a while.



hostname
no service udp-small-servers
no service tcp-small-servers
!
ip subnet-zero
ip classless
!
enable-password <>
!
interface Ethernet 0/0
description To Office Ethernet
ip address
no ip directed broadcast
no shutdown
!
interface Serial 0/0
description To
bandwidth 1536
service-module t1 timeslots 1-24
service-module t1 framing esf
service-module t1 linecode b8zs
service-module t1 clock source internal
encapsulation frame-relay IETF
frame-relay lmi-type ansi
no ip address
no shutdown
no fair-queue
!
interface Serial 0/0.1 point-to-point
ip unnumbered Ethernet0/0
frame-relay interface-dlci 500 IETF
bandwidth 1536
no shutdown
!
ip route 0.0.0.0 0.0.0.0 Serial 0/0.1
no cdp run
no ip http server
!
ip domain-name
ip name-server

End

Alternate serial config.

interface Serial0/0
no ip address
encapsulation frame-relay IETF
service-module t1 timeslots 1-24
service-module t1 framing esf
service-module t1 linecode b8zs
service-module t1 clock source internal
frame-relay lmi-type ansi
load-interval 30
calculations
no fair-queue
bandwidth
!
interface Serial0/0.1 point-to-point
ip addresss XX.XX.XX.XX 255.255.255.252
frame-relay interface-dlci 500 IETF
no ip redirects
no ip proxy-arp
no arp frame-relay
no cdp enable
bandwidth

Friday, August 13, 2010

IE, Chrome and Firefox script to enable or disable proxy settings

For IE and Chrome set the proxy server up on IE and close IE.


Create and new texts file and copy the following into it:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"ProxyEnable"=dword:00000001

File save as proxy.reg then change "ProxyEnable"=dword:00000001 to "ProxyEnable"=dword:00000000 and file save as noproxy.reg

IE and chrome are done just double click proxy.reg if you want the proxy server and noproxy.reg if you don't.


Firefox you need to configure the proxy settings and close Firefox.


Create a new text file and copy the following into it:

//
// user.js: Personal prefs which mozilla shouldn't overwrite.
//

user_pref("network.proxy.type", 1);

File save as ffproxy.txt the change user_pref("network.proxy.type", 1); to user_pref("network.proxy.type", 0); then file save as noffproxy.txt

Now comes the hard part of the Firefox, these files need to be copied in the same place as your prefs.js directory and renamed to user.js depending on what you want. If you want the proxy server enabled then you need to rename ffproxy.txt to user.js in the same directory as prefs.js

Copy C:\Users\ \AppData\Roaming\Mozilla\Firefox\Profiles\ .default\ffproxy.txt to C:\Users\ AppData\Roaming\Mozilla\Firefox\Profiles\ .default\user.js

To disable copy noffproxy.txt

Copy C:\Users\ \AppData\Roaming\Mozilla\Firefox\Profiles\ .default\noffproxy.txt to C:\Users\ AppData\Roaming\Mozilla\Firefox\Profiles\ .default\user.js


:)

Wednesday, August 11, 2010

Setup cannot modify or create the registry entry SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

I was installing TMG sp1 and ran into this error ( Setup cannot modify or create the registry entry SYSTEM\CurrentControlSet\Services\Tcpip\Parameters ) after looking it up I found the answer.

If you downloaded the service pack from the Microsoft Download Center, do the following:

1. Press the SHIFT key and right-click on the .MSP file, and then select Copy as path.

2. Right-click the Command Prompt icon, and then select Run as administrator.

3. Right-click the Command Prompt window and select Paste.

The basic answer is run it in an administrator enabled Command prompt.